Работа с Cisco

Материал из First-Leon
Перейти к: навигация, поиск

Содержание

Настройка программы работы через com порт

#Установка программы
apt-get install minicom
#Ищем com порт
dmesg|grep ttyS
#Настройка параметров
minicom -s

Выставляем порт. Выставляем скорость 9600

#Запуск
sudo minicom

Вывод справки

shift-?

Режим администратора

enable

Просмотр файла конфигурации

sh run  -- 

Краткая информация о портах

sh int desc

Подробная информация о порте

sh int gi0/1

Переход в режим конфигурирования

configure t

Сброс параметров интерфейса в стандартные

defaul interface GigabitInterface 0/13

Добавление порта в vlan

interface GigabitEthernet 0/13
switchport mode access
switchport access vlan 10

Определить в trance или в access вторая сторона

interface GigabitEthernet 0/13
switchport nonegotiate

Включить/выключить порт

interface GigabitEthernet 0/13
no shutdown
shutdown

Создание нового vlan

vlan xxx
name имя
decr описание

Перевести порт в режим быстрой инициализации

spanning-tree portfast

Указать время инициализации порта (время обучения)

spanning-tree [vlan stp-list ] forward-time seconds

Смена административного пароля

enable secret <новый пароль> 

Смена пароля пользователя

username cisco password <новый пароль для этого пользователя>

Сохрание параметров

(old) copy running-config startup-config 	
(new) copy system:running-config nvram:startup-config

Перевод порта в trank-овый режим

interfaces Gi 0/xxx
switchport mode trunk

Включаем SSH. Отключаем telnet:

crypto key generate rsa
1024
line vty 0 4
transport input ssh

Назначаем ip адрес интерфейсу

enable
conf t
int vlan 5
ip address x.x.x.x 255.y.y.y

Указать пароль для telnet

en
conf t
line vty 0 4
login
password pass

Включение в vtp домен

sw(config)# vtp domain <domain-name>

Пароль к vtp домену

sw(config)# vtp password <password>

Режим работы vtp

sw(config)# vtp mode <client | server | transparent>

Сброс пароля на коммутаторе Cisco Catalyst 2950

  • Подключиться к консоли на коммутаторе с помощью кабеля COM-RJ45

Параметры терминального соединения:

бит в секунду (бод): 9600 
бит данных: 8 
четность: нет 
стоп-бит: 1 
контроль передачи: Xon/Xoff 
  • Отключить кабель питания коммутатора.
  • Нажать и удерживать кнопку Mode на коммутаторе, снова подключить кабель питания к коммутатору.
  • Чтобы предотвратить автоматическую загрузку коммутатора (произойдет через 15 секунд), нажать break-последовательность (Ctrl+Break в HyperTerminal) (У меня не успевала загрузиться).
  • После загрузки и появления строки приглашения набрать команду flash_init.
  • Набрать команду load_helper.
  • Набрать команду "dir flash:" (ошибка многих статьей указание набирать "dir flash", нужно именно на конце ":"). Появится список файлов, содержащихся во flash-памяти коммутатора, среди них должен быть файл конфигурации - config.text.
  • Набрать команду rename flash:config.text flash:config.old для переименования

конфигурационного файла.

  • Набрать команду boot.
  • В конце процесса загрузки нажать n, чтобы начать процесс установки.
  • Набрать enable для входа в привилегированный режим, набрать команду rename

flash:config.old config.text.

  • Набрать команды: configure terminal, no enable secret (для сброса пароля,

если он был установлен), enable password cisco (устанавливаем новый пароль cisco).

  • Нажать Ctrl+Z, набрать команду write memory для сохранения параметров.

Перезагрузка

#reload

Просмотр информации о vlan-ах на интерфейсе

show interfaces GigabitEthernet 0/21 trunk

Разрешить vlan на интерфейсе

(config-if)#switchport trunk allowed vlan